Not returning all related products

Home Page Forums WP Related Items Not returning all related products

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author


  • #8949



    I have a woocommerce site with a number of custom taxonomies. The one’s I’m interested in associating are product_collections and stone_colors. With product_collections given highest priority. If I go to single product that is categorized by a product_collection, then the returned related products are the other products in the same collection. Which is what is expected. There are usually no more than 4 products with the same collection category.

    Unfortunately if I view a product with a stone color associated with it then WRI returns maybe 1 or 2 of related products by stone color. Sometimes none. For every stone color category there are many products with this tag. So at the very least I should be getting the set maximum of 4 related each time, although I never do.

    I have Product Collections configured ‘consider with extra weight’ and Stone Colors as ‘consider’

    What am I missing?




    In the background, the YARPP plugin works, its algorithms determine the results.
    The essence of the operation is to weigh the individual elements of similarity, and there is a match threshold that determines how similar elements are included in the results. If there are not enough result, this match threshold should be reduced.

    In the Settings-> YARPP menu, you’ll find a Match Limit field, the default value is 5, try to reduce it until the number of hits you see appears (e.g. set it to 2).

    OR if you would like to specify the match threshold between product and product only, go to the “Products Page” tab on the WP Related Items Settings (Settings -> WP Related Items) page, and set a lower match threshold in the “Products” row.

    You can find more information on the Documentation/FAQ page of WP Related Posts and Products.
    See “What happened if related items do not appear?” question.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.