Manual Relationships Not always working

Home Page Forums WP Related Items Manual Relationships Not always working

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author


  • #5641




    Not all of the manually set relationships are displaying on the front end, and some unrelated items are showing instead.

    For example i have a 8″ telescope product linked to 4 accessories, one of those accessories is a 8″ shroud made specifically for that telescope. For some reason on the front end it is showing three of my selected manual products including the 8″ shroud, as well as a 10″ shroud which is not related to this product at all. If i go to the 8″ shroud product page all the related products are the various different sized shrouds, despite none of them being manually related to each other. Each of those shrouds should just be displaying their relevant size telescope and nothing else.

    It looks as if it is using the product title to decide the related product instead of the manually selected ones, and i have switched everything to “do not consider” in the YARPP settings (except manual relationships). I have also given the “WRI Manual Relationships Weight” a weight of 500.

    I should also add that this doesn’t seem to be happening with all my products, the only ones i have found so far are these telescopes and shrouds.

    I have attached screenshots,


    You must be logged in to view attached files.




    Hello warcher,
    I’ve just had the same problem, took me one hour to reinstall the whole thing and figure out what is happening. Turns out, I’ve had set my posts not to be older than 12 months in YARPP settings. Therefore some of the manually picked ones were not displayed. The moment I’ve turned this setting off, all my manually selected posts were displayed.

    Btw., this note could be a part of the settings page or WRI plugin, just like there is a warning to turn of automatic display of related posts in YARPP settings.

    Hope it helps

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.